关于UglifyJs版本问题导致的报错

最近在跑vue项目的时候碰到了一个问题,出现了一个报错

然后我开始找度娘,然后问题的原因是是由Uglify-js的升级引起的,
详情请参阅:https://github.com/mishoo/UglifyJS2/issues/3394
解决方案是:
使用:

1
2
3
{
"warnings": value
}

代替

1
2
3
4
5
{
"compress": {
"warnings": value
}
}

因为第一次跑公司的vue,找了挺久改文件的位置。是在vue.config.js里修改。